Installing

Installing with pip

Try to install it with

pip install pyswmm

and an attempt will be made to find and install an appropriate version that matches your operating system and Python version.

You can also get pyswmm from the Python Package Index manually at http://pypi.python.org/pypi/pyswmm To use pip, you need to have setuptools installed.

Requirements

Python

To use PySWMM you need Python 2.7, 3.4 or later. Also, this project is currently setup for 32-bit python.